Advertisements were blocked or nothing was served
We understand that advertisements are annoying, and fully support the usage with ads disabled. please support us in any way you can.

Wallet update notification
Due to a network issue on block 3 190 604 for wallets prior to 5.4.6.0, any user running an older wallet is required to update. You can upgrade by going to https://gridcoin.us/#Downloads and selecting your current operating system.

The following news story was loaded from an external source. The story is not related to this site.

5.4.5.6-testnet

Tag: github:gridcoinReleases
Published 2024-03-02 04:14:42

Merge branch 'development' into testnet

Read the story on the source
Disclaimer
All content provided herein our website, hyperlinked sites, associated applications, forums, blogs, social media accounts and other platforms is for your general information only, procured from third party sources. We make no warranties of any kind in relation to our content, including but not limited to accuracy and updatedness. No part of the content that we provide constitutes financial advice, legal advice or any other form of advice meant for your specific reliance for any purpose. Any use or reliance on our content is solely at your own risk and discretion. Sources are Berkeley Open Infrastructure for Network Computing or Gridcoin. Read on what and how you can remove yourself
Rendered in 0.0152s with 3 backend requests in 0.0137s
Memory Usage: 439.98 kb (1.39 mb)
App version: 0a5663d@refs/heads/master
Updated on: