Advertisements were blocked or nothing was served
We understand that advertisements are annoying, and fully support the usage with ads disabled. please support us in any way you can.
Mandatory update in 12.1 days @ block 2671700
The Gridcoin Research wallet v5.4.0.0 is released, which is a mandatory update.
On block 2671700, in about 12.1 days older wallets will no longer be able to connect to the network.
Upgrade to the latest wallet by downloading it from the GitHub repository.
The following news story was loaded from an external source. The story is not related to this site.

5.3.3.12-testnet

Tag: github:gridcoinReleases
Published 2022-07-27 23:10:31

Increment version to 5.3.3.12 for 5.4.0.0 RC1

Read the story on the source
Disclaimer
All content provided herein our website, hyperlinked sites, associated applications, forums, blogs, social media accounts and other platforms is for your general information only, procured from third party sources. We make no warranties of any kind in relation to our content, including but not limited to accuracy and updatedness. No part of the content that we provide constitutes financial advice, legal advice or any other form of advice meant for your specific reliance for any purpose. Any use or reliance on our content is solely at your own risk and discretion. Sources are Berkeley Open Infrastructure for Network Computing or Gridcoin. Read on what and how you can remove yourself
Rendered in 0.0079s with 3 backend requests in 0.0069s
Memory Usage: 416.99 kb (1 mb)
App version: 111493f@refs/heads/master
Updated on: 2022-08-02 20:43:25 +0200